Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




Latest Threads
A guild games (for real this time)
Last Post: Zlinka
05-20-2020 06:34 PM
» Replies: 1
» Views: 1317
Alliance-Horde pet exchange
Last Post: Zlinka
05-16-2020 07:11 AM
» Replies: 3
» Views: 625
Il'gynoth
Last Post: Zlinka
05-14-2020 02:51 PM
» Replies: 1
» Views: 481
Vexiona
Last Post: Zlinka
05-07-2020 05:13 PM
» Replies: 1
» Views: 595
Drest'agath
Last Post: Zlinka
04-22-2020 07:17 AM
» Replies: 3
» Views: 830

Who's Online
There are currently no members online.

Soloing the Chess Event
#1
Hi all,

I know a number of people out there are trying to solo the Chess Event in Karazhan in order to access the Prince for one of the new pets. I found the Chess Event to be really difficult to solo. Nganga pointed me toward a helpful guide -- thanks Nganga! -- which I'm sharing here for my fellow pet collectors!

Karazhan Chess Event: A Soloing Guide

Happy hunting!

-Zlinka
Reply
#2
I've run into a big problem in the event. Once I've controlled my king, then released him, I can never control him again. The little speech bubble will never again appear when I mouse-over him. Same issue with every other piece. So once I've controlled a piece, it goes on autopilot and I can't ever use it again.
Reply
#3
Hrm. I've never had that happen, Anca, but I have noticed that there is a hidden timer that limits how soon you can control a piece after releasing control of one. I usually have to click on the piece 3 or more times and exit out of the window before I will get the little chat bubble option to let me control it.

This may be oversimplifying things, but have you tried a bunch of times on the King? Maybe you are just running into that timer, and by the time you move onto a new piece, it's up and you can control it.

Just a thought. I hope it works out soon!

Avanya
Reply
#4
it finally wasn't broken long enough for me to finish the event. But I know it isn't the "next piece" timer. That's actually a debuff that shows up in the debuff area. No, in my case, after I release a piece, it retains the blue-nameplate designation of "Anca's minion." Also, mousing-over the formerly-controlled piece doesn't even give the option of clicking it again.

When it finally worked again, that didn't happen.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
This forum uses Lukasz Tkacz MyBB addons.